Wamp Server Çalıştırmak

Merhaba arkadaşlar bu yazımda başıma gelen ve çözümünü biraz zaman harcayarak bulabildiğim bir bilgiyi sizlerinde vakit kaybetmemeniz için paylaşmak istiyorum.

Öncelikle Wamp server neden SQL server ve visual studio olan bir bilgisayarsa çalışmaz bunu cevaplayalım. Sebebi hepsinin aynı portu dinlemeleridir.  SQL server Integration service ve IIS bu portu dinlediği için wamp server hizmet veremez.

Bu sorunu aşabilmek için olaya en başından bir bakalım.

Öncelikle kurulum nasıl oluyor ona bakalımn çoğu yerde var ama ben yinede fazla bilgi göz çıkartmaz diyerek başlıyoruz kurmaya…

Kurulurken bizden default bir web browser exe sini belirtmemiz gerekiyor. Eğer Firefox varsa size bu tarayıcıyı varsayılan olarka ayarlamak isteyip istemediğinizi soracak karar sizin artık…

Kurulum biterken localhost ve domain ismi sorar bunlar orada yazdığı gibi kalabilir. Tabi buda size kalmış bir durum isterseniz değiştirebilirsinizde.

Ve kurulum tamamlandığında sağ altta bu programın çalıştığını fakat turuncu bir renkte yani offline durumda olduğunu görüyoruz. Bunun sebebi Sql server içersindeki bazı servislerin ve IIS servislerinin dinledikleri portlarla aynı portları kullanmaya çalıştığından online olamıyor. Peki ne yapmak lazım 😀

Bunun için wamp klasörü  içersinde  yani tam olarak  C:\wamp\bin\apache\Apache2.2.17\conf adresinde httpd.conf dosyasını notepad ile açıyoruz .

Ardından bu dosya içersinde “Listen 80” yazan satırı bularak 80 rakamını herhangi bir rakam yapabilirsiniz. Mesela ben 88 yaptım.

Bu işlemden sonra notepad i kaydedip kapatıyoruz ve ayarların geçerli olabilmesi için wamp server üzerinde Restart All Services  seçeneğini seçerek yeniden başlamasını sağlıyoruz.

Sonunda WAMP Server kullanıma hazır .

Tek bir ayrıntı var çalıştırma işlemi içersinde sadece port numarasını belirtmemiz gerekiyor Örneğin:

http://localhost:88/

http://localhost:88/phpmyadmin/

Umarım yararlı olur.

M.Zeki Osmancık…

28 Responses to “Wamp Server Çalıştırmak”

  1. gezgin Reply

    vuwwwww :)) teşekkürler hocam.. bende
    Could not execute menu item internal error WampServer Hatası port hatasını anlatmıştım sitemde…

  2. Yunus Büyükaydın Reply

    Cok sagolasın tesekkuru borc bildim düzeldi hata 🙂

  3. muzaffer Başer Reply

    süper çok uraştımbilgisayara kaç kere format attım bu sebepten çok teşekkür ederim

  4. fatih fatih Reply

    YOK HOCAM YOK BU DA KAR ETMEDI ÇALIŞMIYOR PROGRAM SKYPE Yİ VİRÜS PROGRAMINI FALAN HEP KALDIRDIM AMA YOK YOK YOK!

    • MEZO Reply

      Bilgisayarında Wamp server in zaten portunu değiştirdiğin için 80 portu ile alakası olmayacaktır. o yüzden skype vs programları kaldırmana gerek yoktu. Amaç zaten IIS ile birlikte wamp çalıştırmak…

  5. muzaffer Başer Reply

    şuan wordpress kurmayı deniyorum ama kurmuyo neden olabilir

  6. Abdurrahman Altunay Reply

    harika bi emek uzun süredir bu hatayi ariyordum ve sonunda basardim, tesekkurederim. Bazi forumlar icerigi gostermek icin uye yapiyorlar sonra isine yaramadigi halde uyelik almak zorunda kaliyorsun sizin boyle bir uygulamaniz olmadigi icin memnunum.

  7. orhan yenici Reply

    büyüksün hocaaaam.. gece sahurdan beri bununla uğraşıyom 😀

  8. hakkifeyzi Reply

    ben bu olayı da denedim. ama hala olmadı nedenini 2 gündür araştırıyorum olmadı..arkadaşlar başka bir tahmini olan var mı ?

  9. ByZavzu Reply

    Tebrik Ederim. Webde uzunca bir zamandır aradığım bir cevap. Bilgine ve emeğine saygı duyuyorum. Teşekkürler

  10. Muhammet bozdağ Reply

    Yakışıyormu bi microsoftcuya bunlar ya 🙂

  11. ferhat Reply

    teşekkür ederim hocam valla database filan hepsi gidiyordu tekrar teşekkür ederim saygılar

  12. hayri ali camdereli Reply

    dedginiz gibi yaptım ama bu seferde foribden 403 hatası veriyor:S

  13. Murat BAKAR Reply

    Gerçekten eline sağlık çok yardımcı ve yararlı oldu.

    (paylaşılmayan bilgi bilgi değildir)

  14. Tamer YEŞİL Reply

    Değerli bilgiler için teşekkür ederim. Gerçekten çok işime yaradı.

  15. mehmet Reply

    Hepsi bumu sabahtan uğraşıyorum 🙂 Çok teşekkürler…

  16. burcubuffy Reply

    ben de uzun süredir bu problemle uğrasıyorum. bu yolu da denedim ama olmuyor maalesef. turuncudan yeşile dönmüyor. ilk kurduğumda böyle bir sorun yoktu. sonra ne olduysa böyle oldu. birkaç kere wamp’ı kaldırıp yeniden kurdum. fayda etmedi. başka bir önerisi olan var mı??

    • mezo Reply

      sonradan kurduğun programlardan dolayı olabilir wamp serveri kurduktan sonra PC ne kurduğun programları bi kontrol et istersen. onu kaldırdığında sorunun çözülür.

  17. uur Reply

    Deveye Hendek Atlatan Adam Bu Makale İçin Teşekkür Eder

  18. Cenk Reply

    Hocam harika bir kaynak hazırlamışsın. Ancak ben localhost yazdığımda giriş yapmıyor sadece localhost:88 yazdığımda yönetim paneli çıkıyor nede olabilir?

    • M.Zeki Osmancık Reply

      çünkü localhost u visual studio için ayırdın. localhost:88 yazarsan wamp server için ayrılan porttan işlem yapacaksın. kullanman gereken yöntem o zaten localhost:88

  19. engin keser Reply

    yok hocam dediğiniz gibi yaptığım halde gene olmuyor. kaldı turuncuda, birtürlü yeşil olmuyor.
    nette de hep sizin dediğiniz yöntem var. başka bir çaresi yokmu bunun. Bilgisayar daha sıfır yani yeni format atmıştım. herhangi bir oyun veya yazılım yüklü değil.

    • M.Zeki Osmancık Reply

      80 portunu meşgul eden bir program varsa Skype gibi belki o yapar onun dışında alakasız bir port numarası verebilirsin 99 ,199 gibi kullanılmayan port olması önemli

Leave a Reply

Please type the characters of this captcha image in the input box

Please type the characters of this captcha image in the input box